Update: Web-Features 2012


Irgendwie hat mir das Problem mit dem DENIC-Konverter keine Ruhe gelassen, da ich beim DENIC nicht an Fehler glauben mag. Ich tue nur ungern irgendwem Unrecht – glaube aber trotzdem zuerst an das, was ich sehe. Also müssen Vergleichsdaten her. Was macht denn ein anderer Konverter? Und vor allem WARUM? Eine Gegenprobe bei phlyLabs Berlin ergibt jedenfalls auch den ACE-String xn--zcaj8cya.eitico.de. Es ist also scheinbar tatsächlich die gewünschte Zieldomain mit ‘ß’. Aber wie kommt dann das Browserverhalten zustande?

Des Rätsels Lösung sind wieder einmal die Standards. Bei IDNA2003 wird das ‘ß’ zu ‘ss’ aufgelöst. Aus ‘äöüß’ wird so ‘äöüss’ – und das ergibt dann nun einmal xn--ss-uia6e4a.eitico.de. Nach IDNA2008 wird das ‘ß’ jedoch gleich kodiert und ergibt xn--zcaj8cya.eitico.de. (Quelle)

Natürlich haben meine Browser auf meinem Primär-Rechner (XP::SP3) davon keinen blassen Dunst bzw. keine Ahnung. Ob das bei den aktuellen Browsern unter Vista bzw. 7 funktioniert, muß ich testen. Ebenfalls interessant, was unter Linux so passiert. In einer ruhigen Minute checke ich das mal. Allerdings würde es mich nicht wundern, wenn es noch keine breite Unterstützung für IDNA2008 gäbe. Das würde zumindest erklären, warum sich 1&1 so dezent zurückhält.

 

IDNA-fähige Software (Quelle)

DENIC IDN-Web-Converter

Libraries

Libidn2 (Fortsetzung GNU Libidn, ab Release 0.3)
ICU (ab Release 4.6)
IDNKIT (ab Release 2.0)
VeriSign IDN SDK (ab Version 4.0)
Net-IDN-Encode (ab Release 2.0)

Browser

Opera 11.60 und höher

IDN2003-fähige Programme (Quelle)
Browser
  • Mozilla Firefox 0.6 und höher (früher Mozilla Firebird)
  • Netscape 7.1 und höher
  • Opera 7.11 und höher
  • OmniWeb 5
  • Microsoft Internet Explorer 7
  • Microsoft Internet Explorer 6.0 und höher + EchIDNA
  • Microsoft Internet Explorer 5.0 und höher + Verisign i-Nav TM PlugIn
  • Konqueror (ab KDE 3.2 + GNU IDN Library)
  • Epiphany 1.2.2 und höher
  • Galeon 1.3.14 und höher
  • Safari 1.2 und höher
  • Mozilla Camino 0.7 und höher
  • AmigaOS AWeb 3.5 und höher
E-Mail
  • MS Outlook 2k, 2k2 (XP), 2k3; Outlook Express 5 u. höher +Verisign i-Nav PlugIn
  • Foxmail 5.0 und höher
  • VisNetic MailServer 7.2.4 build 0 und höher
  • Merak Mail Server 7.4.0 und höher
  • PHlyMail
  • AmigaOS SimpleMail 0.25 und höher
  • Mutt
FTP-Clients
  • SmartFTP 1.0 Build 980
  • Core FTP Version 1.3a
  • SecureFTP 4.0.2004 Release und höher
  • FTP Voyager 11.0 und höher
ssh / telnet-Clients
  • SecureNetTerm 4.0.2004 Beta Release und höher
  • AbsoluteTelnet 3.13 und höher

Die Kommentarfunktion ist geschlossen.